aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-29 16:48:48 +0000
committersaturneric <[email protected]>2024-07-29 16:48:48 +0000
commitef4f152a53853c97af2bd2817d936a9338d8deb3 (patch)
treebcd4ca30c764937017b1297c75d1c9908cab8fa5 /src/CMakeLists.txt
parentfix: should build mimalloc separately (diff)
downloadGpgFrontend-ef4f152a53853c97af2bd2817d936a9338d8deb3.tar.gz
GpgFrontend-ef4f152a53853c97af2bd2817d936a9338d8deb3.zip
fix: should not install mimalloc after build
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c25d1fb1..28f30f13 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -521,10 +521,6 @@ if(LINUX AND LINUX_INSTALL_SOFTWARE)
gpgfrontend_ui
gpgfrontend_test
gpgfrontend_module_sdk)
-
- if(NOT APPLE)
- list(APPEND GPGFRONTEND_INSTALL_LIBRARIES mimalloc)
- endif()
endif()
message(STATUS "GpgFrontend Install Libraries: ${GPGFRONTEND_INSTALL_LIBRARIES}")
@@ -570,10 +566,6 @@ if(STABLE_BUILD_FULL_SDK)
gpgfrontend_test
gpgfrontend_module_sdk)
- if(NOT APPLE)
- list(APPEND GPGFRONTEND_SDK_INSTALL_LIBRARIES mimalloc)
- endif()
-
install(TARGETS ${GPGFRONTEND_SDK_INSTALL_LIBRARIES}
EXPORT GpgFrontendTargets
PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}