aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-29 16:29:50 +0000
committersaturneric <[email protected]>2024-07-29 16:29:50 +0000
commit7054d32ee25bafdbfe01aaa9f0bade54d03431ff (patch)
tree9ee55fe84b93cc42ffbc1a2a6ad7a0af878e6572 /src/CMakeLists.txt
parentfix: add option --no-translations by windeployqt (diff)
downloadGpgFrontend-7054d32ee25bafdbfe01aaa9f0bade54d03431ff.tar.gz
GpgFrontend-7054d32ee25bafdbfe01aaa9f0bade54d03431ff.zip
fix: should build mimalloc separately
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 723cf364..c25d1fb1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,7 +56,9 @@ endif()
find_package(OpenSSL REQUIRED)
# mimalloc
-find_package(mimalloc REQUIRED)
+if(NOT APPLE)
+ find_package(mimalloc REQUIRED)
+endif()
# Set Build Information
configure_file(${CMAKE_SOURCE_DIR}/src/GpgFrontend.h.in ${CMAKE_SOURCE_DIR}/src/GpgFrontend.h @ONLY)