aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-08-05 15:29:04 +0000
committersaturneric <[email protected]>2024-08-05 15:29:04 +0000
commit512c2198507bcfa4367e39163edf8b626a3008a9 (patch)
tree7039371d43fe1f9989856d504f7a42c3b40ea6eb /src/CMakeLists.txt
parentfix: addressing some of the significant deficiencies identified (diff)
downloadGpgFrontend-512c2198507bcfa4367e39163edf8b626a3008a9.tar.gz
GpgFrontend-512c2198507bcfa4367e39163edf8b626a3008a9.zip
fix: remove mimalloc from source
Too bad, under Flatpak or even under Windows, this library can cause the program to crash. The reason for this is that there are some places that do not override the memory allocation method, but this does not guarantee that the mimalloc library will be loaded first in some environments (especially Flatpak) so I think it would be better to let the user install it themselves rather than include this library. Then override all mallocs as needed, which is easy to do. Sacrificing some of the security of the default state for the stability of the program feels necessary to me.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 08b6e3a1..51239a4a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -55,11 +55,6 @@ endif()
find_package(OpenSSL REQUIRED)
-# mimalloc
-if(NOT APPLE)
- find_package(mimalloc REQUIRED)
-endif()
-
# Set Build Information
configure_file(${CMAKE_SOURCE_DIR}/src/GpgFrontend.h.in ${CMAKE_SOURCE_DIR}/src/GpgFrontend.h @ONLY)
configure_file(${CMAKE_SOURCE_DIR}/src/GpgFrontendBuildInfo.h.in ${CMAKE_SOURCE_DIR}/src/GpgFrontendBuildInfo.h @ONLY)
@@ -284,14 +279,6 @@ if(BUILD_APPLICATION AND MINGW)
list(APPEND ALL_RUNTIME_DEP_PATH_LIST ${_libDllPath})
unset(_libDllPath)
- file(GLOB _libDllPath "${MSYS64_BIN_PATH}/libmimalloc*.dll")
- list(APPEND ALL_RUNTIME_DEP_PATH_LIST ${_libDllPath})
-
- unset(_libDllPath)
- file(GLOB _libDllPath "${MSYS64_BIN_PATH}/mimalloc*.dll")
- list(APPEND ALL_RUNTIME_DEP_PATH_LIST ${_libDllPath})
-
- unset(_libDllPath)
file(GLOB _libDllPath "${MSYS64_BIN_PATH}/libarchive*.dll")
list(APPEND ALL_RUNTIME_DEP_PATH_LIST ${_libDllPath})