aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-31 06:13:26 +0000
committersaturneric <[email protected]>2024-07-31 06:13:26 +0000
commit081147d65fcb0a20818bbfb43f6ec4f5ddf59581 (patch)
treef6ec05666acb98da46b4cb0dfc0871225f4ad388 /src/CMakeLists.txt
parentfix: dealing with unknown compiler (diff)
downloadGpgFrontend-081147d65fcb0a20818bbfb43f6ec4f5ddf59581.tar.gz
GpgFrontend-081147d65fcb0a20818bbfb43f6ec4f5ddf59581.zip
fix: addressing some of the significant deficiencies identified
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ddbc0fae..08b6e3a1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -569,6 +569,12 @@ endif()
# if only build sdk
if(STABLE_BUILD_ONLY_SDK)
include(GNUInstallDirs)
+
+ if(INSTALL_TO_MODULES_REPO)
+ set(CMAKE_INSTALL_PREFIX "${CMAKE_SOURCE_DIR}/modules/sdk/${CMAKE_PROJECT_VERSION}")
+ message(STATUS "Set CMake Install Prefix for Cooperation: ${CMAKE_INSTALL_PREFIX}")
+ endif()
+
set(GPGFRONTEND_SDK_INSTALL_LIBRARIES
gpgfrontend_module_sdk)
@@ -584,6 +590,11 @@ endif()
if(STABLE_BUILD_FULL_SDK)
include(GNUInstallDirs)
+ if(INSTALL_TO_MODULES_REPO)
+ set(CMAKE_INSTALL_PREFIX "${CMAKE_SOURCE_DIR}/modules/sdk/${CMAKE_PROJECT_VERSION}")
+ message(STATUS "Set CMake Install Prefix for Cooperation: ${CMAKE_INSTALL_PREFIX}")
+ endif()
+
set(GPGFRONTEND_SDK_INSTALL_LIBRARIES
gpgfrontend_core
gpgfrontend_ui