aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gpu/drm/amd/amdgpu/gfx_v8_0.h
Commit message (Collapse)AuthorAgeFilesLines
* drm/amdgpu: unify MQD programming sequence for kfd and amdgpu v2Andres Rodriguez2017-05-311-0/+5
| | | | | | | | | | | | | | Use the same gfx_*_mqd_commit function for kfd and amdgpu codepaths. This removes the last duplicates of this programming sequence. v2: fix cp_hqd_pq_wptr value Reviewed-by: Edward O'Callaghan <[email protected]> Acked-by: Christian König <[email protected]> Reviewed-by: Felix Kuehling <[email protected]> Signed-off-by: Andres Rodriguez <[email protected]> Signed-off-by: Alex Deucher <[email protected]>
* drm/amdgpu: rework IP block registration (v2)Alex Deucher2016-10-251-1/+2
| | | | | | | | | | | | | This makes it easier to replace specific IP blocks on asics for handling virtual_dce, DAL, etc. and for building IP lists for hw or tables. This also stored the status information in the same structure. v2: split out spelling fix into a separate patch add a function to add IPs to the list Reviewed-by: Christian König <[email protected]> Signed-off-by: Alex Deucher <[email protected]>
* drm/amdgpu/gfx8: remove stale function declarationAlex Deucher2016-08-081-2/+0
| | | | | | | | This got leftover somehow when I cleaned this up. Reviewed-by: Christian König <[email protected]> Reviewed-by: Chunming Zhou <[email protected]> Signed-off-by: Alex Deucher <[email protected]>
* drm/amdgpu: move get_gpu_clock_counter into the gfx structAlex Deucher2016-07-071-1/+0
| | | | | | | | It's gfx IP specific, not asic specific, so move to a gfx callback. Reviewed-by: Chunming Zhou <[email protected]> Signed-off-by: Alex Deucher <[email protected]>
* drm/amdgpu: fetch cu_info once at initAlex Deucher2016-05-111-1/+0
| | | | | | | | Fetch this info once at init and just store the results for future requests. Reviewed-by: Christian König <[email protected]> Signed-off-by: Alex Deucher <[email protected]>
* drm/amdgpu: rename amdgpu_ip_funcs to amd_ip_funcs (v2)yanyang12015-06-041-1/+1
| | | | | | | | | | | | The structure is renamed and moved to amd_shared.h to make the component independent. This makes it easier to add new components in the future. v2: fix include path Reviewed-by: Jammy Zhou <[email protected]> Signed-off-by: yanyang1 <[email protected]> Signed-off-by: Alex Deucher <[email protected]>
* drm/amdgpu: Add initial VI supportAlex Deucher2015-06-041-0/+33
This adds initial support for VI asics. This includes Iceland, Tonga, and Carrizo. Our inital focus as been Carrizo, so there are still gaps in support for Tonga and Iceland, notably power management. Acked-by: Christian König <[email protected]> Acked-by: Jammy Zhou <[email protected]> Signed-off-by: Alex Deucher <[email protected]>