aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gpg/Makefile.am
diff options
context:
space:
mode:
authorIngo Klöcker <[email protected]>2021-07-08 10:18:45 +0000
committerIngo Klöcker <[email protected]>2021-07-08 10:18:45 +0000
commita5662a801fc11a533fb3b1a69a17e119064972a3 (patch)
tree8004aaf9b4bddfeefa6d9878ba45a01af5c7dae3 /tests/gpg/Makefile.am
parentMake sure expiration time is interpreted as unsigned number (diff)
downloadgpgme-a5662a801fc11a533fb3b1a69a17e119064972a3.tar.gz
gpgme-a5662a801fc11a533fb3b1a69a17e119064972a3.zip
core: Ensure gpg.conf for tests is recreated if necessary
* tests/gpg/gpg.conf.in: New. * tests/gpg/Makefile.am (gpg.conf): Copy gpg.conf.in instead of using echo to fill gpg.conf. -- This change ensures that gpg.conf is updated whenever new options are added for some tests.
Diffstat (limited to 'tests/gpg/Makefile.am')
-rw-r--r--tests/gpg/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/tests/gpg/Makefile.am b/tests/gpg/Makefile.am
index d24a312f..bb90ccb6 100644
--- a/tests/gpg/Makefile.am
+++ b/tests/gpg/Makefile.am
@@ -101,11 +101,8 @@ pubring-stamp: $(srcdir)/pubdemo.asc gpg-sample.stamp
--import $(srcdir)/secdemo.asc
echo x > ./pubring-stamp
-gpg.conf:
-# This is required for t-sig-notations.
- echo no-force-v3-sigs > ./gpg.conf
-# This is required for t-edit-sign.
- echo allow-weak-key-signatures >> ./gpg.conf
+gpg.conf: $(srcdir)/gpg.conf.in
+ cp $(srcdir)/gpg.conf.in gpg.conf
gpg-agent.conf:
# This is required for gpg2, which does not support command fd for the