aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gpg/Makefile.am
diff options
context:
space:
mode:
authorAlon Bar-Lev <[email protected]>2016-10-19 09:04:07 +0000
committerWerner Koch <[email protected]>2016-11-11 08:09:40 +0000
commit41d8c7e51a8989be633b9ada124c58a01fae7d54 (patch)
tree707d3d24748e31a214e0d2ec9d1a9e1a57005374 /tests/gpg/Makefile.am
parentcore: Use better error code when using select with a too high fd. (diff)
downloadgpgme-41d8c7e51a8989be633b9ada124c58a01fae7d54.tar.gz
gpgme-41d8c7e51a8989be633b9ada124c58a01fae7d54.zip
tests,python: Atomic directory creation
* lang/python/tests/Makefile.am: Use MIDIR_P. * tests/gpg/Makefile.am: Ditto. * tests/gpgsm/Makefile.am: Ditto. -- Solves race in parallel build when mkdir fails if directory exists. Signed-off-by: Alon Bar-Lev <[email protected]> - Tweaked the ChangeLog Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'tests/gpg/Makefile.am')
-rw-r--r--tests/gpg/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/gpg/Makefile.am b/tests/gpg/Makefile.am
index dd33b0a2..c46feb07 100644
--- a/tests/gpg/Makefile.am
+++ b/tests/gpg/Makefile.am
@@ -93,7 +93,7 @@ export GNUPGHOME := $(abs_builddir)
export GPG_AGENT_INFO :=
./private-keys-v1.d/gpg-sample.stamp: $(srcdir)/$(private_keys)
- test -d ./private-keys-v1.d || mkdir ./private-keys-v1.d
+ $(MKDIR_P) ./private-keys-v1.d
for k in $(private_keys); do \
cp $(srcdir)/$$k private-keys-v1.d/$$k.key; \
done