aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gpg/Makefile.am
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2017-05-10 13:49:54 +0000
committerJustus Winter <[email protected]>2017-05-10 13:49:54 +0000
commit15adff073bb89dc032d8342cfbbdad2850943f52 (patch)
tree44e6ec951459d8c398e5892c829520df46c1503f /tests/gpg/Makefile.am
parentqt: Stop agent on clean. (diff)
downloadgpgme-15adff073bb89dc032d8342cfbbdad2850943f52.tar.gz
gpgme-15adff073bb89dc032d8342cfbbdad2850943f52.zip
tests: Harmonize test suites.
* lang/python/tests/Makefile.am: Create test environment as part of 'make all'. * tests/gpg/Makefile.am: Make sure the private keystore is created first. * tests/gpgsm/Makefile.am: Create test environment as part of 'make all'. Make sure the private keystore is created first. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'tests/gpg/Makefile.am')
-rw-r--r--tests/gpg/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/gpg/Makefile.am b/tests/gpg/Makefile.am
index 1d9a6dfe..ed1323b4 100644
--- a/tests/gpg/Makefile.am
+++ b/tests/gpg/Makefile.am
@@ -95,7 +95,7 @@ export GPG_AGENT_INFO :=
done
echo x > ./private-keys-v1.d/gpg-sample.stamp
-./pubring-stamp: $(srcdir)/pubdemo.asc
+./pubring-stamp: $(srcdir)/pubdemo.asc ./private-keys-v1.d/gpg-sample.stamp
$(GPG) --batch --no-permission-warning \
--import $(srcdir)/pubdemo.asc
-$(GPG) --batch --no-permission-warning \