aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2001-11-22 03:01:26 +0000
committerMarcus Brinkmann <[email protected]>2001-11-22 03:01:26 +0000
commit790a8e192f54e811f83d5b817463890528efda7a (patch)
treee2f91f70f8a353dcec872967800ce5ce7c3eb0e5 /tests/Makefile.am
parentcorrected includes (diff)
downloadgpgme-790a8e192f54e811f83d5b817463890528efda7a.tar.gz
gpgme-790a8e192f54e811f83d5b817463890528efda7a.zip
2001-11-22 Marcus Brinkmann <[email protected]>
* gpg/: New directory. * Makefile.am, t-verify.c, t-encrypt.c, t-signers.c, t-trustlist.c, t-sign.c, t-keylist.c, t-import.c, t-genkey.c, t-export.c, t-decrypt-verify.c, t-decrypt.c, t-version.c, t-data.c, mkdemodirs. cipher-1.asc, cipher-2.asc, geheim.txt, pubdemo.asc, pubkey-1.asc, secdemo.asc, seckey-1.asc): Move to sub directory gpg/. * gpg/Makefile.am (INCLUDES): Include gpgme/, not include/ and intl/. (LDD): Correct relative path to gpgme library. (TESTS): Remove t-version and t-data. * gpg/t-verify.c, gpg/t-encrypt.c, gpg/t-signers.c, gpg/t-trustlist.c, gpg/t-sign.c, gpg/t-keylist.c, gpg/t-import.c, gpg/t-genkey.c, gpg/t-export.c, gpg/t-decrypt-verify.c, gpg/t-decrypt.c, t-version.c, t-data.c): Include gpgme.h, not "../gpgme/gpgme.h". * Makefile.am: New file. * gpgsm/: New directory. * gpgsm/Makefile.am: New file.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am42
1 files changed, 15 insertions, 27 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 64906988..b3679179 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,40 +19,28 @@
## Process this file with automake to produce Makefile.in
-
TESTS_ENVIRONMENT = GNUPGHOME=.
-TESTS = t-version t-data t-encrypt t-sign t-signers t-decrypt t-verify \
- t-decrypt-verify t-keylist t-export t-import t-trustlist
-
+TESTS = t-version t-data
-EXTRA_DIST = mkdemodirs pubdemo.asc secdemo.asc cipher-1.asc geheim.txt \
- pubkey-1.asc seckey-1.asc
+EXTRA_DIST = t-data-1.txt t-data-2.txt
-INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl
+INCLUDES = -I$(top_srcdir)/gpgme
LDADD = ../gpgme/libgpgme.la
-# We don't run t-genkey in the test suite, because it taes too long
-noinst_PROGRAMS = $(TESTS) t-genkey
-
-distclean-local:
- $(srcdir)/mkdemodirs --clean
-
-all-local: ./pubring.gpg ./secring.gpg
-
-./pubring.gpg: $(srcdir)/pubdemo.asc
- -gpg --homedir . --import $(srcdir)/pubdemo.asc
-
-./secring.gpg: ./Alpha/Secret.gpg
- -gpg --homedir . --allow-secret-key-import --import Alpha/Secret.gpg Zulu/Secret.gpg
-
-./Alpha/Secret.gpg: secdemo.asc
- srcdir=$(srcdir) $(srcdir)/mkdemodirs
-
-
-
-
+noinst_PROGRAMS = $(TESTS)
+if RUN_GPG_TESTS
+gpgtests = gpg
+else
+gpgtests =
+endif
+if RUN_GPGSM_TESTS
+gpgsmtests = gpgsm
+else
+gpgsmtests =
+endif
+SUBDIRS = ${gpgtests} ${gpgsmtests}