aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2021-11-25 10:43:33 +0000
committerWerner Koch <[email protected]>2021-11-25 10:43:33 +0000
commit43de18a292b29436783127bd6c275817f0cd86b7 (patch)
tree3a7833def0ad0491e63e600ad1334676c40ce4d1 /tests/Makefile.am
parentcore: Support dirinfo("socketdir") (diff)
downloadgpgme-43de18a292b29436783127bd6c275817f0cd86b7.tar.gz
gpgme-43de18a292b29436783127bd6c275817f0cd86b7.zip
tests: Silence libtool warning on Windows.
* tests/Makefile.am (AM_LDFLAGS): Use --no-fast-install on Windows.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e4346576..20315675 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -28,7 +28,13 @@ TESTS = t-version t-data t-engine-info
EXTRA_DIST = start-stop-agent t-data-1.txt t-data-2.txt ChangeLog-2011
AM_CPPFLAGS = -I$(top_builddir)/src @GPG_ERROR_CFLAGS@
+
+if HAVE_W32_SYSTEM
+AM_LDFLAGS = -no-fast-install
+else
AM_LDFLAGS = -no-install
+endif
+
LDADD = ../src/libgpgme.la @GPG_ERROR_LIBS@ @LDADD_FOR_TESTS_KLUDGE@
noinst_HEADERS = run-support.h