aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python/setup.py
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-05-10 11:30:30 +0000
committerJustus Winter <[email protected]>2016-05-10 11:30:30 +0000
commitaade53a12b9716997684b872bc2ac87229f73fb3 (patch)
tree3b7765c59ff99c7929a3e08053bcd2f301a1ceec /lang/python/setup.py
parentpython: Drop Debian packaging. (diff)
downloadgpgme-aade53a12b9716997684b872bc2ac87229f73fb3.tar.gz
gpgme-aade53a12b9716997684b872bc2ac87229f73fb3.zip
python: Delete trailing whitespace.
-- Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'lang/python/setup.py')
-rwxr-xr-xlang/python/setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/setup.py b/lang/python/setup.py
index b0ed3b2c..562c08f4 100755
--- a/lang/python/setup.py
+++ b/lang/python/setup.py
@@ -60,7 +60,7 @@ for item in getconfig('cflags'):
# Adjust include and library locations in case of win32
uname_s = os.popen("uname -s").read()
if uname_s.startswith("MINGW32"):
- mnts = [x.split()[0:3:2] for x in os.popen("mount").read().split("\n") if x]
+ mnts = [x.split()[0:3:2] for x in os.popen("mount").read().split("\n") if x]
tmplist = sorted([(len(x[1]), x[1], x[0]) for x in mnts])
tmplist.reverse()
extra_dirs = []
@@ -89,9 +89,9 @@ except OSError as e:
raise RuntimeError("Could not call swig, perhaps install swig.")
else:
raise
-
+
subprocess.call(["make swig"], shell=True)
-
+
swige = Extension("pyme._pygpgme", ["gpgme_wrap.c", "helpers.c"],
include_dirs = include_dirs,
define_macros = define_macros,
@@ -106,7 +106,7 @@ setup(name = "pyme",
url = version.homepage,
ext_modules=[swige],
packages = ['pyme', 'pyme.constants', 'pyme.constants.data',
- 'pyme.constants.keylist', 'pyme.constants.sig'],
+ 'pyme.constants.keylist', 'pyme.constants.sig'],
license = version.copyright + \
", Licensed under the GPL version 2 and the LGPL version 2.1"
)