aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Greiner (bnavigator) <[email protected]>2023-03-16 14:09:38 +0000
committerWerner Koch <[email protected]>2023-03-17 09:06:55 +0000
commitd086653cc346d5634bc742d5586e927fc9ee57cf (patch)
treef939afcd5ec45db251fda2f34496f2150346a20c /configure.ac
parenttests: Package the ownertrust file (diff)
downloadgpgme-d086653cc346d5634bc742d5586e927fc9ee57cf.tar.gz
gpgme-d086653cc346d5634bc742d5586e927fc9ee57cf.zip
python: Update python.m4 configure script.
* configure.ac: Unset PYTHON_LIBS. Support python 3.10. * m4/python.m4: Find correct version string for python >= 3.10. -- See-also: https://dev.gnupg.org/D546 Also test for 3.11 and 3.12 (wk).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dfcaac31..83ac09de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -521,11 +521,13 @@ if test "$found_py" = "1"; then
if test "$found_py" = "1" -o "$found_py3" = "1"; then
# Reset everything, so that we can look for another Python.
m4_foreach([mym4pythonver],
- [[2.7],[3.4],[3.5],[3.6],[3.7],[3.8],[3.9],[all]],
+ [[2.7],[3.4],[3.5],[3.6],[3.7],[3.8],[3.9],[3.10],
+ [3.11],[3.12],[all]],
[unset PYTHON
unset PYTHON_VERSION
unset PYTHON_CPPFLAGS
unset PYTHON_LDFLAGS
+ unset PYTHON_LIBS
unset PYTHON_SITE_PKG
unset PYTHON_EXTRA_LIBS
unset PYTHON_EXTRA_LDFLAGS