aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIngo Klöcker <[email protected]>2022-10-10 12:30:41 +0000
committerIngo Klöcker <[email protected]>2022-10-10 12:46:39 +0000
commit8e908029ffa03d21662030d3111dcf556b722e1a (patch)
tree11f675f7ae6dd6360bf51bbbf82e58c38c0029fe /configure.ac
parentcore: Fix SIG_CREATED status parsing for 0x1F sigs (diff)
downloadgpgme-8e908029ffa03d21662030d3111dcf556b722e1a.tar.gz
gpgme-8e908029ffa03d21662030d3111dcf556b722e1a.zip
build,qt: Explicitly namespace a few Qt variables for Qt5
m4/qt.m4: Rename to m4/qt5.m4: this. (FIND_QT): Rename to FIND_QT5. (GPGME_QT): Change variable prefix to GPGME_QT5. (GPGME_QTTEST: Change variable prefix to GPGME_QT5TEST. configure.ac, lang/qt/src/Makefile.am, lang/qt/tests/Makefile.am: Adjust accordingly. -- In preparation to adding support for building qgpgme for Qt6, add the version number to a few variables to avoid confusion.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e7fe04a7..8fcf14f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,7 +375,7 @@ if test "$found" = "1"; then
*** Qt language binding depends on cpp binding.
***]])
fi
- FIND_QT
+ FIND_QT5
if test "$have_qt5_libs" != "yes"; then
if test "$explicit_languages" = "1"; then
AC_MSG_ERROR([[
@@ -408,7 +408,7 @@ LIST_MEMBER("qt", $enabled_languages)
if test "$found" = "1"; then
AX_GCC_FUNC_ATTRIBUTE(visibility)
if test "$ax_cv_have_func_attribute_visibility" = "yes"; then
- GPGME_QT_CFLAGS="$GPGME_QT_CFLAGS -fvisibility=hidden"
+ GPGME_QT5_CFLAGS="$GPGME_QT5_CFLAGS -fvisibility=hidden"
fi
fi