aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2018-12-17 15:47:06 +0000
committerWerner Koch <[email protected]>2018-12-17 15:47:27 +0000
commit8b41fb08f00f01fe0dd8b2b5455d3422d97ddc60 (patch)
treef3c215ce09bc0a8ead706238b5e95931434d0a24 /configure.ac
parentpython: howto and examples (diff)
downloadgpgme-8b41fb08f00f01fe0dd8b2b5455d3422d97ddc60.tar.gz
gpgme-8b41fb08f00f01fe0dd8b2b5455d3422d97ddc60.zip
core: Silence newer compiler warnings.
* configure.ac: Add -Wno-format-truncation and -Wno-sizeof-pointer-div. * src/b64dec.c (_gpgme_b64dec_proc): Add fallthrough annotation. * src/cJSON.c (parse_string): Ditto. * src/gpgme-json.c (main): Ditto. -- gcc 8 enables a couple of new warnings. Some of them are useless for us. In particular: util.h:42:26: warning: division 'sizeof (char *) / sizeof (char)' does not compute the number of array elements [-Wsizeof-pointer-div] #define DIM(v) (sizeof(v)/sizeof((v)[0])) ^ trustlist.c:101:22: note: in expansion of macro 'DIM' if (strlen (p) == DIM(item->keyid) - 1) Which is a real standard way to use DIM, here the right hand side is equivalent to sizeof but nevertheless it is correct. Yes sir, we know C. The format string warnings I have seen were assuming that the time structure returns valued out of scope - but if the system is that broken, the s_n_printf catches this. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b607e0b..ff37794f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -582,6 +582,8 @@ if test "$GCC" = yes; then
CFLAGS="$CFLAGS -Wno-missing-field-initializers"
CFLAGS="$CFLAGS -Wno-sign-compare"
CFLAGS="$CFLAGS -Wno-format-zero-length"
+ CFLAGS="$CFLAGS -Wno-format-truncation"
+ CFLAGS="$CFLAGS -Wno-sizeof-pointer-div"
fi
CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wno-shadow"