aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2021-11-25 02:13:17 +0000
committerNIIBE Yutaka <[email protected]>2021-11-25 02:13:17 +0000
commit8148237cb4ae20755c06a44d71761c7030973c3d (patch)
treeaaa3d581d5094f436a6ec353f390b25f902d206d /configure.ac
parentgpgme.pc: Fix library dependency and use of includedir, libdir. (diff)
downloadgpgme-8148237cb4ae20755c06a44d71761c7030973c3d.tar.gz
gpgme-8148237cb4ae20755c06a44d71761c7030973c3d.zip
posix: Use poll instead, when available, removing use of select.
* configure.ac (HAVE_POLL_H): Add the check. * src/ath.c [!HAVE_POLL_H] (ath_select): Enable conditionally. * src/posix-io.c [HAVE_POLL_H] (_gpgme_io_select_poll): Use poll. * tests/gpg/t-cancel.c [HAVE_POLL_H] (do_select): Use poll. * tests/gpg/t-eventloop.c [HAVE_POLL_H] (do_select): Use poll. -- GnuPG-bug-id: 2385 Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 296553e3..4ce30677 100644
--- a/configure.ac
+++ b/configure.ac
@@ -538,7 +538,7 @@ AM_CONDITIONAL(RUN_G13_TESTS, test "$run_g13_test" = "yes")
# Checks for header files.
AC_CHECK_HEADERS_ONCE([locale.h sys/select.h sys/uio.h argp.h stdint.h
- unistd.h sys/time.h sys/types.h sys/stat.h])
+ unistd.h poll.h sys/time.h sys/types.h sys/stat.h])
# Type checks.