aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2021-08-13 05:52:03 +0000
committerNIIBE Yutaka <[email protected]>2021-08-13 05:52:03 +0000
commit3c1c98a43413e429459ca7d3615659f8149534b8 (patch)
tree2f05ddd18a00d563e783b2c5e53acdb3354b4eea /configure.ac
parentcore: Fix results returned by gpgme_data_* functions (diff)
downloadgpgme-3c1c98a43413e429459ca7d3615659f8149534b8.tar.gz
gpgme-3c1c98a43413e429459ca7d3615659f8149534b8.zip
core: Use flexible array member if compiler has support.
* configure.ac (AC_C_FLEXIBLE_ARRAY_MEMBER): Add. * src/engine-gpg.c (struct arg_and_data_s): Use FLEXIBLE_ARRAY_MEMBER. (_add_arg): Use offsetof instead of sizeof. (add_data): Likewise. -- Before this fix, GCC 11 warns (with its bound checking feature). Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cefc090..296553e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -543,6 +543,7 @@ AC_CHECK_HEADERS_ONCE([locale.h sys/select.h sys/uio.h argp.h stdint.h
# Type checks.
AC_C_INLINE
+AC_C_FLEXIBLE_ARRAY_MEMBER
AC_CHECK_SIZEOF(unsigned int)
AC_SYS_LARGEFILE
AC_TYPE_OFF_T