aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2018-10-31 11:27:27 +0000
committerWerner Koch <[email protected]>2018-10-31 11:35:14 +0000
commit3c04dea3ecebed35208f6b631b2e8b04222ea432 (patch)
treeb8dbdf9bbceed60e1b2f9b4615e0a3d1dad9d550 /configure.ac
parentw32: Remove cruft in w32-io from WindowsME times. (diff)
downloadgpgme-3c04dea3ecebed35208f6b631b2e8b04222ea432.tar.gz
gpgme-3c04dea3ecebed35208f6b631b2e8b04222ea432.zip
w32: Remove all support for WindowsCE
* configure.ac: Remove WindwosCE support. * contrib/: Remove all; it was only used for WindowsCE. * src/w32-ce.c, src/w32-ce.h: Remove files. * src/Makefile.am (system_components): Remove these files. * src/ath.c, src/ath.h: Remove W32CE support. * src/data-compat.c (gpgme_data_new_from_filepart): Ditto. (gpgme_data_new_from_file): Ditto. * src/debug.c (debug_init, _gpgme_debug): Ditto. * src/gpgme-tool.c (gpgme_server): Ditto. (main): Ditto. * src/priv-io.h: Do not include w32-ce.h. * src/util.h: Remove WindowsCE support. * src/w32-io.c: Ditto. * src/w32-util.c: Ditto. * src/debug.h (TRACE_SUC4): New. -- There is no more hardware to test our code, the support for Windows CE terminated along time ago. Note that our code worked only with the old WindowsCE with that overall system limit of 31 processes. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 1493554d..13989931 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,9 +186,6 @@ case "${host}" in
x86_64-*mingw32*)
have_w64_system=yes
;;
- *-mingw32ce*)
- have_w32ce_system=yes
- ;;
*-linux-androideabi)
have_android_system=yes
;;
@@ -197,7 +194,7 @@ case "${host}" in
;;
esac
case "${host}" in
- *-mingw32ce*|*-mingw32*)
+ *-mingw32*)
have_dosish_system=yes
have_w32_system=yes
GPG_DEFAULT='c:\\gnupg\\gpg.exe'
@@ -241,12 +238,6 @@ if test "$have_w64_system" = yes; then
fi
AM_CONDITIONAL(HAVE_W64_SYSTEM, test "$have_w64_system" = yes)
-if test "$have_w32ce_system" = yes; then
- AC_DEFINE(HAVE_W32CE_SYSTEM,1,
- [Defined if we run on a W32 CE API based system])
-fi
-AM_CONDITIONAL(HAVE_W32CE_SYSTEM, test "$have_w32ce_system" = yes)
-
if test "$have_android_system" = yes; then
AC_DEFINE(HAVE_ANDROID_SYSTEM,1, [Defined if we build for an Android system])
fi