aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorIngo Klöcker <[email protected]>2025-01-15 13:44:36 +0000
committerIngo Klöcker <[email protected]>2025-01-15 13:44:36 +0000
commitf6403a998f812b95534c1b6911b4ae5590c0d970 (patch)
tree9361df3aa23273df15441c10de59e90c341bda75 /Makefile.am
parentbuild: Remove defining GPG_ERR_ENABLE_ERRNO_MACROS. (diff)
downloadgpgme-f6403a998f812b95534c1b6911b4ae5590c0d970.tar.gz
gpgme-f6403a998f812b95534c1b6911b4ae5590c0d970.zip
build: Fix generation of ChangeLog on secondary working trees
* Makefile.am (gen-ChangeLog): Use test -e instead of test -d to check for git working trees. -- In secondary working trees (created with `git worktree add ...`) .git is a file referencing the original .git directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 71046b2f..66595201 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -74,7 +74,7 @@ distcheck-hook:
gen_start_date = 2011-12-01T00:00:00
gen-ChangeLog:
- if test -d $(top_srcdir)/.git; then \
+ if test -e $(top_srcdir)/.git; then \
(cd $(top_srcdir) && \
$(GITLOG_TO_CHANGELOG) --append-dot --tear-off \
--amend=build-aux/git-log-fix \