aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2011-12-02 10:32:31 +0000
committerWerner Koch <[email protected]>2011-12-02 10:36:37 +0000
commita4c4ee1aaea4359432bdf60dd572f549ef8dee83 (patch)
tree479a4c6baca2d581bfbd5f195d80b7255fd5ad38 /Makefile.am
parentRemove support for libgpgme-pth. (diff)
downloadgpgme-a4c4ee1aaea4359432bdf60dd572f549ef8dee83.tar.gz
gpgme-a4c4ee1aaea4359432bdf60dd572f549ef8dee83.zip
Generate the ChangeLog from commit logs.
* build-aux/gitlog-to-changelog: New script. Taken from gnulib. * build-aux/git-log-fix: New file. * build-aux/git-log-footer: New file. * build-aux/git-hook/commit-msg: New script. * doc/HACKING: New file. * ChangeLog: New file. * Makefile.am (EXTRA_DIST): Add new files. (gen-ChangeLog): New. (dist-hook): Run gen-ChangeLog. * autogen.sh: Install commit-msg hook for git. Rename all ChangeLog files to ChangeLog-2011.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 23 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index fb068670..1ab445d2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,19 +1,19 @@
# Makefile.am - Top level Makefile for GPGME.
# Copyright (C) 2000 Werner Koch (dd9jn)
# Copyright (C) 2001, 2002, 2004, 2005, 2008, 2009 g10 Code GmbH
-#
+#
# This file is part of GPGME.
-#
+#
# GPGME is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as
# published by the Free Software Foundation; either version 2.1 of the
# License, or (at your option) any later version.
-#
+#
# GPGME is distributed in the hope that it will be useful, but WITHOUT
# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General
# Public License for more details.
-#
+#
# You should have received a copy of the GNU Lesser General Public
# License along with this program; if not, see <http://www.gnu.org/licenses/>.
@@ -24,21 +24,36 @@ AUTOMAKE_OPTIONS = dist-bzip2
DISTCHECK_CONFIGURE_FLAGS = --with-gpg="@GPG@"
-EXTRA_DIST = gpgme.spec.in autogen.sh
+EXTRA_DIST = gpgme.spec.in autogen.sh \
+ ChangeLog-2011 m4/ChangeLog-2011 contrib/ChangeLog-2011
if RUN_GPG_TESTS
tests = tests
else
-tests =
+tests =
endif
SUBDIRS = src ${tests} doc lang
-# Fix the version of the spec file and create a file named VERSION
+# Fix the version of the spec file and create a file named VERSION
# to be used for patch's Prereq: feature.
-dist-hook:
+dist-hook: gen-ChangeLog
@set -e; \
sed -e 's/@pkg_version@/$(VERSION)/g' \
$(top_srcdir)/gpgme.spec.in > $(distdir)/gpgme.spec
echo "$(VERSION)" > $(distdir)/VERSION
+
+
+gen_start_date = 2011-12-01T00:00:00
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d $(top_srcdir)/.git; then \
+ (cd $(top_srcdir) && \
+ ./build-aux/gitlog-to-changelog \
+ --amend=build-aux/git-log-fix \
+ --since=$(gen_start_date) ) > $(distdir)/cl-t; \
+ cat $(top_srcdir)/build-aux/git-log-footer >> $(distdir)/cl-t;\
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi