aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2019-09-20 05:19:18 +0000
committerNIIBE Yutaka <[email protected]>2019-09-20 05:19:18 +0000
commitbb5ed9fe1abfcbb6128325508366bc802eb576c5 (patch)
tree99054eeb7e88519c1b91ba82a7bd98bb7f0aaf94 /tools/Makefile.am
parenttools: Fix gpg-pair-tool to follow new API. (diff)
downloadgnupg-bb5ed9fe1abfcbb6128325508366bc802eb576c5.tar.gz
gnupg-bb5ed9fe1abfcbb6128325508366bc802eb576c5.zip
build: Build gpg-pair-tool only when there is newer libgcrypt.
* configure.ac (HAVE_NEWER_LIBGCRYPT): New. * tools/Makefile.am: Conditionalize build of gpg-pair-tool. Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index fb37c05e7..9df9d4c46 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -49,7 +49,7 @@ else
gpg_wks_server =
endif
-libexec_PROGRAMS = gpg-wks-client gpg-pair-tool
+libexec_PROGRAMS = gpg-wks-client
bin_PROGRAMS = gpgconf gpg-connect-agent gpg-card ${symcryptrun}
if !HAVE_W32_SYSTEM
@@ -187,6 +187,8 @@ gpg_wks_client_LDADD = $(libcommon) \
$(LIBASSUAN_LIBS) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
$(LIBINTL) $(LIBICONV)
+if HAVE_NEWER_LIBGCRYPT
+libexec_PROGRAMS += gpg-pair-tool
gpg_pair_tool_SOURCES = \
gpg-pair-tool.c
@@ -194,7 +196,7 @@ gpg_pair_tool_CFLAGS = $(GPG_ERROR_CFLAGS) $(INCICONV)
gpg_pair_tool_LDADD = $(libcommon) \
$(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
$(LIBINTL) $(LIBICONV) $(W32SOCKLIBS)
-
+endif
# Make sure that all libs are build before we use them. This is
# important for things like make -j2.