aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2024-06-28 15:51:18 +0000
committerWerner Koch <[email protected]>2024-06-28 15:59:55 +0000
commit28a080bc9f9478f63a7edffa420512eaed3555ff (patch)
tree29951164e078052a6daf3c8adce78921cdbe83a1 /tools/Makefile.am
parenttools: New support functions for the mail parser. (diff)
downloadgnupg-28a080bc9f9478f63a7edffa420512eaed3555ff.tar.gz
gnupg-28a080bc9f9478f63a7edffa420512eaed3555ff.zip
gpg-mail-tube: New utility.
* tools/gpg-mail-tube.c: new. * tools/Makefile.am: Add it.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 9321da9e3..3769d6606 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -65,7 +65,8 @@ endif
bin_PROGRAMS = gpgconf gpg-connect-agent gpg-card gpg-wks-client
if !HAVE_W32_SYSTEM
-bin_PROGRAMS += watchgnupg gpgparsemail ${gpg_wks_server} gpgsplit
+bin_PROGRAMS += watchgnupg gpgparsemail ${gpg_wks_server} gpgsplit \
+ gpg-mail-tube
else
bin_PROGRAMS += gpgconf-w32
endif
@@ -190,6 +191,17 @@ gpg_wks_client_LDADD = $(libcommon) \
$(LIBINTL) $(LIBICONV) $(NETLIBS) \
$(gpg_wks_client_rc_objs)
+gpg_mail_tube_SOURCES = \
+ gpg-mail-tube.c \
+ rfc822parse.c rfc822parse.h \
+ mime-maker.c mime-maker.h
+
+gpg_mail_tube_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS) $(INCICONV)
+gpg_mail_tube_LDADD = $(libcommon) \
+ $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
+ $(LIBINTL) $(LIBICONV)
+
+
gpg_pair_tool_SOURCES = \
gpg-pair-tool.c