aboutsummaryrefslogtreecommitdiffstats
path: root/tests/cms/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2023-10-06 08:57:12 +0000
committerWerner Koch <[email protected]>2023-10-06 09:02:19 +0000
commit24b3a5a5794db4bb69b38a1df099d5e59cccf2b3 (patch)
tree893efd27508a994f75a05aa99931addf557a454b /tests/cms/Makefile.am
parenttests:tpm2dtests: Modify tests with SWTPM and relax the condition. (diff)
downloadgnupg-24b3a5a5794db4bb69b38a1df099d5e59cccf2b3.tar.gz
gnupg-24b3a5a5794db4bb69b38a1df099d5e59cccf2b3.zip
sm: Support more HMAC algos in the pkcs#12 parser.
* sm/minip12.c (oid_hmacWithSHA1): New. Also for the SHA-2 algos. (digest_algo_from_oid): New. (set_key_iv_pbes2): Add arg digest_algo. (crypt_block): Ditto. (decrypt_block): Ditto. (parse_bag_encrypted_data): Parse the optional prf part and get the hmac algorithm. (parse_shrouded_key_bag): Ditto. (p12_build): Pass SHA1 for digest_algo. * sm/t-minip12.c (run_one_test): Print failed values in verbose mode. * tests/cms/samplekeys/nistp256-openssl-self-signed.p12: New. * tests/cms/samplekeys/Description-p12: Add this one. * tests/cms/Makefile.am (EXTRA_DIST): Ditto. -- This supports the modern algorithms, i.e. using SHA256 for the KDF which is the default in openssl unless the -legacy option is used. GnuPG-bug-id: 6536
Diffstat (limited to 'tests/cms/Makefile.am')
-rw-r--r--tests/cms/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/cms/Makefile.am b/tests/cms/Makefile.am
index d5d753902..b43fb1c91 100644
--- a/tests/cms/Makefile.am
+++ b/tests/cms/Makefile.am
@@ -100,6 +100,7 @@ EXTRA_DIST = $(XTESTS) $(KEYS) $(CERTS) $(TEST_FILES) \
samplekeys/t5793-openssl.pfx \
samplekeys/t5793-test.pfx \
samplekeys/[email protected] \
+ samplekeys/nistp256-openssl-self-signed.p12 \
samplemsgs/pwri-sample.cbc.p7m \
samplemsgs/pwri-sample.cbc-2.p7m \
samplemsgs/pwri-sample.gcm.p7m \