aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-08-09 18:16:02 +0000
committerWerner Koch <[email protected]>2002-08-09 18:16:02 +0000
commitbeb0fef1eef30923cb563c2a0efd38ce9847f53f (patch)
treec0b5d0cab49fb5642f3ca2e692eb17f324ac5544 /tests/Makefile.am
parent* signal.c: New. Taken from GnuPG 1.1.91. (diff)
downloadgnupg-beb0fef1eef30923cb563c2a0efd38ce9847f53f.tar.gz
gnupg-beb0fef1eef30923cb563c2a0efd38ce9847f53f.zip
Tweaked the build system so that make distcheck finanly said Well
Done.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 12 insertions, 19 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ac0e6cb8c..442d86435 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,17 +24,23 @@ GPGSM = ../sm/gpgsm
# We can't unset a variable here so we unset GPG_AGENT_INFO in runtest
TESTS_ENVIRONMENT = GNUPGHOME=`pwd` LC_ALL=C GPGSM=$(GPGSM) $(srcdir)/runtest
-EXTRA_DIST = runtest inittests \
+testscripts = sm-sign+verify sm-verify
+
+EXTRA_DIST = runtest inittests $(testscripts) \
text-1.txt text-2.txt text-3.txt \
text-1.osig.pem text-1.dsig.pem text-1.osig-bad.pem \
- text-2.osig.pem text-2.osig-bad.pem
+ text-2.osig.pem text-2.osig-bad.pem \
+ samplekeys/32100C27173EF6E9C4E9A25D3D69F86D37A4F939.key \
+ samplekeys/cert_g10code_pete1.pem \
+ samplekeys/cert_g10code_test1.pem \
+ samplekeys/cert_g10code_theo1.pem
-TESTS = sm-sign+verify sm-verify
+TESTS = $(testscripts)
CLEANFILES = inittests.stamp x y y z out err
*.lock .\#lk*
-DISTCLEANFILES = keyring.kbx~ random_seed
+DISTCLEANFILES = pubring.kbx~ random_seed
noinst_PROGRAMS = asschk
@@ -44,22 +50,9 @@ asschk_SOURCES = asschk.c
all-local: inittests.stamp
clean-local:
- $(TESTS_ENVIRONMENT) $(srcdir)/inittests --clean
+ srcdir=$(srcdir) $(TESTS_ENVIRONMENT) $(srcdir)/inittests --clean
inittests.stamp: inittests
- $(TESTS_ENVIRONMENT) $(srcdir)/inittests
+ srcdir=$(srcdir) $(TESTS_ENVIRONMENT) $(srcdir)/inittests
echo timestamp >./inittests.stamp
-# Include all files listed in the samplekeys/distfiles
-dist-hook:
- @set -e; \
- dir=$(srcdir)/samplekeys ; \
- $(mkinstalldirs) $(distdir)/$$dir ; \
- for i in distfiles `cat $$dir/distfiles` ; do \
- ln $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
- || cp -p $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
- done
-
-
-
-