aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-09-30 14:22:40 +0000
committerJustus Winter <[email protected]>2016-10-04 11:23:17 +0000
commit4a232d23a8f51bebf9ee382e480248b4bde30f28 (patch)
tree160c2de5f7fcfcad3b82e2b2e264199cdaf13cf3 /tests/Makefile.am
parenttests,w32: Do not expose 'glob' to gpgscm. (diff)
downloadgnupg-4a232d23a8f51bebf9ee382e480248b4bde30f28.tar.gz
gnupg-4a232d23a8f51bebf9ee382e480248b4bde30f28.zip
build,w32: Unconditionally build tests.
* configure.ac (run_tests, RUN_TESTS, RUN_GPG_TESTS): Remove variables. They are misleadingly named, as they inhibit building the tests. There is no reason not to build the tests even when cross-compiling, as they are only run if one does 'make check'. * Makefile: Adapt accordingly. * tests/Makefile.am: Adapt accordingly. Avoid building 'asschk' on Windows as it uses non-portable functions. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d72f51e8b..6ede0d409 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,14 +18,7 @@
## Process this file with automake to produce Makefile.in
-
-if RUN_GPG_TESTS
-openpgp = openpgp
-else
-openpgp =
-endif
-
-SUBDIRS = gpgscm ${openpgp} . migrations pkits
+SUBDIRS = gpgscm openpgp migrations pkits .
GPGSM = ../sm/gpgsm
@@ -66,7 +59,9 @@ CLEANFILES = inittests.stamp x y y z out err \
DISTCLEANFILES = pubring.kbx~ random_seed
+if !HAVE_W32_SYSTEM
noinst_PROGRAMS = asschk
+endif
asschk_SOURCES = asschk.c