aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-08-09 14:44:59 +0000
committerWerner Koch <[email protected]>2002-08-09 14:44:59 +0000
commit0e43a5795325e8921ff1294ebaf7b9de055e134e (patch)
tree1f0ca0cd0cf0a1d3ee8d58ff3f3a987ca0469191 /tests/Makefile.am
parent* options.skel: Some language tweaks, and remove the load-extension (diff)
downloadgnupg-0e43a5795325e8921ff1294ebaf7b9de055e134e.tar.gz
gnupg-0e43a5795325e8921ff1294ebaf7b9de055e134e.zip
Added distfiles kludge to distribute the content of the samplekeys directory.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 15c2e4cb7..ac0e6cb8c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,7 +22,7 @@
GPGSM = ../sm/gpgsm
# We can't unset a variable here so we unset GPG_AGENT_INFO in runtest
-TESTS_ENVIRONMENT = GNUPGHOME=`pwd` LC_ALL=C GPGSM=${GPGSM} ./runtest
+TESTS_ENVIRONMENT = GNUPGHOME=`pwd` LC_ALL=C GPGSM=$(GPGSM) $(srcdir)/runtest
EXTRA_DIST = runtest inittests \
text-1.txt text-2.txt text-3.txt \
@@ -50,6 +50,15 @@ inittests.stamp: inittests
$(TESTS_ENVIRONMENT) $(srcdir)/inittests
echo timestamp >./inittests.stamp
+# Include all files listed in the samplekeys/distfiles
+dist-hook:
+ @set -e; \
+ dir=$(srcdir)/samplekeys ; \
+ $(mkinstalldirs) $(distdir)/$$dir ; \
+ for i in distfiles `cat $$dir/distfiles` ; do \
+ ln $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
+ || cp -p $(srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
+ done