aboutsummaryrefslogtreecommitdiffstats
path: root/scd/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2013-04-25 11:00:16 +0000
committerWerner Koch <[email protected]>2013-05-07 19:35:48 +0000
commit88e24341e57c96e31a25e92e09d67989e64cc1c1 (patch)
treec9a8b053f02d3143a8f881448610c3c1d8bc211a /scd/Makefile.am
parentdoc: fix some Texinfo warnings. (diff)
downloadgnupg-88e24341e57c96e31a25e92e09d67989e64cc1c1.tar.gz
gnupg-88e24341e57c96e31a25e92e09d67989e64cc1c1.zip
w32: Add icons and version information.
* common/gnupg.ico: New. Take from artwork/gnupg-favicon-1.ico. * agent/gpg-agent-w32info.rc: New. * g10/gpg-w32info.rc: New. * scd/scdaemon-w32info.rc: New. * sm/gpgsm-w32info.rc: New. * tools/gpg-connect-agent-w32info.rc: New. * common/w32info-rc.h.in: New. * configure.ac (BUILD_REVISION, BUILD_FILEVERSION, BUILD_TIMESTAMP) (BUILD_HOSTNAME): New. (AC_CONFIG_FILES): Add w32info-rc.h. * am/cmacros.am (.rc.o): New rule. * agent/Makefile.am, common/Makefile.am, g10/Makefile.am * scd/Makefile.am, sm/Makefile.am, tools/Makefile.am: Add stuff to build resource files. -- Signed-off-by: Werner Koch <[email protected]> (cherry picked from commit 049b3d9ca0285d15c00c215ac9b533c994196ca4) Solved conflicts in: agent/Makefile.am common/Makefile.am g10/Makefile.am scd/Makefile.am sm/Makefile.am tools/Makefile.am
Diffstat (limited to 'scd/Makefile.am')
-rw-r--r--scd/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/scd/Makefile.am b/scd/Makefile.am
index 1af13d0aa..577b4a092 100644
--- a/scd/Makefile.am
+++ b/scd/Makefile.am
@@ -17,7 +17,7 @@
## Process this file with automake to produce Makefile.in
-EXTRA_DIST = ChangeLog-2011
+EXTRA_DIST = ChangeLog-2011 scdaemon-w32info.rc
if HAVE_W32_SYSTEM
libexec_PROGRAMS = scdaemon
@@ -29,6 +29,10 @@ AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/common
include $(top_srcdir)/am/cmacros.am
+if HAVE_W32_SYSTEM
+resource_objs += scdaemon-w32info.o
+endif
+
AM_CFLAGS = $(LIBGCRYPT_CFLAGS) \
$(KSBA_CFLAGS) $(LIBASSUAN_CFLAGS) $(NPTH_CFLAGS)
@@ -48,7 +52,7 @@ scdaemon_SOURCES = \
scdaemon_LDADD = $(libcommonpth) ../gl/libgnu.a \
$(LIBGCRYPT_LIBS) $(KSBA_LIBS) $(LIBASSUAN_LIBS) $(NPTH_LIBS) \
$(LIBUSB_LIBS) $(GPG_ERROR_LIBS) \
- $(LIBINTL) $(DL_LIBS) $(NETLIBS) $(LIBICONV)
+ $(LIBINTL) $(DL_LIBS) $(NETLIBS) $(LIBICONV) $(resource_objs)
# Removed for now: We need to decide whether it makes sense to
# continue it at all, given that gpg has now all required