aboutsummaryrefslogtreecommitdiffstats
path: root/regexp/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2020-04-03 06:30:08 +0000
committerNIIBE Yutaka <[email protected]>2020-04-03 06:30:08 +0000
commitba247a114c75a84473c11c1484013b09fbb9bcd1 (patch)
treea76cedce73621da0142ceb7d71ae51cad8696ec3 /regexp/Makefile.am
parentscd:p15: Implement do_with_keygrip and capabilities. (diff)
downloadgnupg-ba247a114c75a84473c11c1484013b09fbb9bcd1.tar.gz
gnupg-ba247a114c75a84473c11c1484013b09fbb9bcd1.zip
gpg: Add regular expression support.
* AUTHORS, COPYING.other: Update. * Makefile.am (SUBDIRS): Add regexp sub directory. * configure.ac (DISABLE_REGEX): Remove. * g10/Makefile.am (needed_libs): Add libregexp.a. * g10/trustdb.c: Remove DISABLE_REGEX support. * regexp/LICENSE, regexp/jimregexp.c, regexp/jimregexp.h, regexp/utf8.c, regexp/utf8.h: New from Jim Tcl. * regexp/UnicodeData.txt: New from Unicode. * regexp/Makefile.am, regexp/parse-unidata.awk: New. * tests/openpgp/Makefile.am: Remove DISABLE_REGEX support. * tools/Makefile.am: Remove DISABLE_REGEX support. GnuPG-bug-id: 4843 Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'regexp/Makefile.am')
-rw-r--r--regexp/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/regexp/Makefile.am b/regexp/Makefile.am
new file mode 100644
index 000000000..a4e9fce0b
--- /dev/null
+++ b/regexp/Makefile.am
@@ -0,0 +1,38 @@
+# Makefile for common gnupg modules
+# Copyright (C) 2020 g10 Code GmbH
+#
+# This file is part of GnuPG.
+#
+# GnuPG is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# GnuPG is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in
+
+noinst_LIBRARIES = libregexp.a
+
+AM_CPPFLAGS = -DJIM_REGEXP -DJIM_UTF8 -DUSE_UTF8
+
+AM_CFLAGS =
+
+libregexp_a_SOURCES = jimregexp.h utf8.h jimregexp.c utf8.c
+libregexp_a_CFLAGS = $(AM_CFLAGS)
+
+EXTRA_DIST = parse-unidata.awk UnicodeData.txt _unicode_mapping.c
+
+if MAINTAINER_MODE
+BUILT_SOURCES = _unicode_mapping.c
+MAINTAINERCLEANFILES = _unicode_mapping.c
+
+_unicode_mapping.c: parse-unidata.awk UnicodeData.txt
+ $(AWK) -f $(srcdir)/parse-unidata.awk $(srcdir)/UnicodeData.txt >$@
+endif