aboutsummaryrefslogtreecommitdiffstats
path: root/g13/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2009-09-23 10:28:41 +0000
committerWerner Koch <[email protected]>2009-09-23 10:28:41 +0000
commit1d0e9816e4a665da90d4798d7814b4e93346d7a9 (patch)
treee6c206190a7b62c709deec56bd88e2d4e964f22d /g13/Makefile.am
parent2009-09-23 Marcus Brinkmann <[email protected]> (diff)
downloadgnupg-1d0e9816e4a665da90d4798d7814b4e93346d7a9.tar.gz
gnupg-1d0e9816e4a665da90d4798d7814b4e93346d7a9.zip
s/DOTLOCK/dotlock_t/.
Add some stuff for g13.
Diffstat (limited to 'g13/Makefile.am')
-rw-r--r--g13/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/g13/Makefile.am b/g13/Makefile.am
new file mode 100644
index 000000000..dce2f0b04
--- /dev/null
+++ b/g13/Makefile.am
@@ -0,0 +1,35 @@
+# g13/Makefile.am
+# Copyright (C) 2009 Free Software Foundation, Inc.
+#
+# This file is part of GnuPG.
+#
+# GnuPG is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# GnuPG is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in
+
+bin_PROGRAMS = g13
+
+AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/common
+
+include $(top_srcdir)/am/cmacros.am
+
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS)
+
+g13_SOURCES = \
+ g13.c g13.h
+
+g13_LDADD = $(libcommon) ../jnlib/libjnlib.a ../gl/libgnu.a \
+ $(LIBGCRYPT_LIBS) $(LIBASSUAN_LIBS) $(GPG_ERROR_LIBS) \
+ $(LIBINTL)
+