aboutsummaryrefslogtreecommitdiffstats
path: root/g10/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2022-12-09 05:02:07 +0000
committerNIIBE Yutaka <[email protected]>2022-12-09 05:06:08 +0000
commitf32d0c9c0ff7a62d17e6c46e0e21fe00be22c114 (patch)
tree8d597dde88fddd5e8f14aa5ace5861b43f17b079 /g10/Makefile.am
parentwkd: Do not send/install/mirror expired user ids. (diff)
downloadgnupg-f32d0c9c0ff7a62d17e6c46e0e21fe00be22c114.tar.gz
gnupg-f32d0c9c0ff7a62d17e6c46e0e21fe00be22c114.zip
build: Remove Windows CE support.
* agent/Makefile.am [HAVE_W32CE_SYSTEM]: Remove. * am/cmacros.am [HAVE_W32CE_SYSTEM]: Remove. * autogen.sh: Remove W32ce_ variables. * configure.ac: Likewise. * dirmngr/Makefile.am (extra_bin_ldflags): Remove. * g10/Makefile.am [HAVE_W32CE_SYSTEM]: Remove. * kbx/Makefile.am: Likewise. * sm/Makefile.am (extra_bin_ldflags): Remove. * tools/Makefile.am (extra_bin_ldflags): Remove. -- Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'g10/Makefile.am')
-rw-r--r--g10/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 3fd38517b..80b5b8919 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -47,9 +47,7 @@ endif
# NB: We use noinst_ for gpg and gpgv so that we can install them with
# the install-hook target under the name gpg2/gpgv2.
noinst_PROGRAMS = gpg
-if !HAVE_W32CE_SYSTEM
noinst_PROGRAMS += gpgv
-endif
noinst_PROGRAMS += $(module_tests)
if DISABLE_TESTS
TESTS =
@@ -173,12 +171,12 @@ LDADD = $(needed_libs) ../common/libgpgrl.a \
$(ZLIBS) $(LIBINTL) $(CAPLIBS)
gpg_LDADD = $(LDADD) $(SQLITE3_LIBS) $(LIBGCRYPT_LIBS) $(LIBREADLINE) \
$(LIBASSUAN_LIBS) $(NPTH_LIBS) $(GPG_ERROR_LIBS) $(NETLIBS) \
- $(LIBICONV) $(resource_objs) $(extra_sys_libs)
-gpg_LDFLAGS = $(extra_bin_ldflags)
+ $(LIBICONV) $(resource_objs)
+gpg_LDFLAGS =
gpgv_LDADD = $(LDADD) $(LIBGCRYPT_LIBS) \
$(LIBASSUAN_LIBS) $(NPTH_LIBS) $(GPG_ERROR_LIBS) $(NETLIBS) \
- $(LIBICONV) $(resource_objs) $(extra_sys_libs)
-gpgv_LDFLAGS = $(extra_bin_ldflags)
+ $(LIBICONV) $(resource_objs)
+gpgv_LDFLAGS =
t_common_ldadd =