aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-09-01 09:18:10 +0000
committerWerner Koch <[email protected]>2016-09-01 09:18:10 +0000
commitbabeb6f8a9b1f8341652145bad58be6cd49e0712 (patch)
treebbf1bb628c6a1ddde3852e81f56ad23a08c53491 /dirmngr/Makefile.am
parentwks: Send a final message to the user. (diff)
downloadgnupg-babeb6f8a9b1f8341652145bad58be6cd49e0712.tar.gz
gnupg-babeb6f8a9b1f8341652145bad58be6cd49e0712.zip
tests: Run test requiring the network only in maintainer-mode.
* dirmngr/Makefile.am (noinst_PROGRAMS, TESTS): Add module_net_tests. (module_tests): Move t-dns-test to ... (module_net_tests): here. -- Debian-bug-id: 836259 Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'dirmngr/Makefile.am')
-rw-r--r--dirmngr/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 64bc05868..6b0a1e1b7 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -28,8 +28,8 @@ if USE_LDAPWRAPPER
libexec_PROGRAMS = dirmngr_ldap
endif
-noinst_PROGRAMS = $(module_tests) $(module_maint_tests)
-TESTS = $(module_tests)
+noinst_PROGRAMS = $(module_tests) $(module_net_tests) $(module_maint_tests)
+TESTS = $(module_tests) $(module_net_tests)
AM_CPPFLAGS = -I$(top_srcdir)/common
@@ -114,12 +114,20 @@ t_common_ldadd = $(libcommon) $(LIBASSUAN_LIBS) $(LIBGCRYPT_LIBS) \
$(NTBTLS_LIBS) $(LIBGNUTLS_LIBS) \
$(DNSLIBS) $(LIBINTL) $(LIBICONV)
-module_tests = t-dns-stuff
+module_tests =
if USE_LDAP
module_tests += t-ldap-parse-uri
endif
+# Test which need a network connections are only used in maintainer mode.
+if MAINTAINER_MODE
+module_net_tests = t-dns-stuff
+else
+module_net_tests =
+endif
+
+# Tests which are only for manually testing are only build in maintainer-mode.
if MAINTAINER_MODE
module_maint_tests = t-http
else