aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-12-14 09:21:16 +0000
committerWerner Koch <[email protected]>2016-12-14 14:57:16 +0000
commit392966aed9b2a5e1456c671e5d13b561a27e4bb2 (patch)
tree21d60c1ff5be5e5b9a3024cee01c11b9b5b8ffcf /dirmngr/Makefile.am
parentdoc: Add license notes for libdns. (diff)
downloadgnupg-392966aed9b2a5e1456c671e5d13b561a27e4bb2.tar.gz
gnupg-392966aed9b2a5e1456c671e5d13b561a27e4bb2.zip
dirmngr: Require a c99 compiler
* configure.ac (USE_C99_CFLAGS): New ac_subst. Set to -std=gnu99 for gcc. * dirmngr/Makefile.am (AM_CFLAGS): Add USE_C99_CFLAGS. (t_http_CFLAGS): Ditto. (t_ldap_parse_uri_CFLAGS): Ditto. (t_dns_stuff_CFLAGS): Ditto. -- C99 and the GCC option is required for use with dns.c which makes heavy use of C99 features. We should consider to switch GnuPG entirely to C99 but enable gcc warnings to detect features which are not supported by not-real-c99 compilers and which makes audits harder (VLA etc.). Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'dirmngr/Makefile.am')
-rw-r--r--dirmngr/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 5c294688d..f18786b8d 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -35,7 +35,8 @@ AM_CPPFLAGS = -I$(top_srcdir)/common
include $(top_srcdir)/am/cmacros.am
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS) $(LIBASSUAN_CFLAGS) \
+AM_CFLAGS = $(USE_C99_CFLAGS) \
+ $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS) $(LIBASSUAN_CFLAGS) \
$(GPG_ERROR_CFLAGS) $(NPTH_CFLAGS) $(NTBTLS_CFLAGS) \
$(LIBGNUTLS_CFLAGS)
@@ -132,7 +133,7 @@ endif
# http tests
t_http_SOURCES = $(t_common_src) t-http.c http.c dns-stuff.c
-t_http_CFLAGS = -DWITHOUT_NPTH=1 \
+t_http_CFLAGS = -DWITHOUT_NPTH=1 $(USE_C99_CFLAGS) \
$(LIBGCRYPT_CFLAGS) $(NTBTLS_CFLAGS) $(LIBGNUTLS_CFLAGS) \
$(GPG_ERROR_CFLAGS)
t_http_LDADD = $(t_common_ldadd) \
@@ -142,11 +143,11 @@ t_ldap_parse_uri_SOURCES = \
t-ldap-parse-uri.c ldap-parse-uri.c ldap-parse-uri.h \
http.c dns-stuff.c \
$(ldap_url) $(t_common_src)
-t_ldap_parse_uri_CFLAGS = -DWITHOUT_NPTH=1 \
+t_ldap_parse_uri_CFLAGS = -DWITHOUT_NPTH=1 $(USE_C99_CFLAGS) \
$(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
t_ldap_parse_uri_LDADD = $(ldaplibs) $(t_common_ldadd) $(DNSLIBS)
-t_dns_stuff_CFLAGS = -DWITHOUT_NPTH=1 \
+t_dns_stuff_CFLAGS = -DWITHOUT_NPTH=1 $(USE_C99_CFLAGS) \
$(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
t_dns_stuff_SOURCES = $(t_common_src) t-dns-stuff.c dns-stuff.c
t_dns_stuff_LDADD = $(t_common_ldadd) $(DNSLIBS)