aboutsummaryrefslogtreecommitdiffstats
path: root/dirmngr/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2020-08-20 08:54:17 +0000
committerWerner Koch <[email protected]>2020-08-20 08:54:17 +0000
commit32aac55875f324f8c3d85dad8483604eae65e3e8 (patch)
tree4dd9ebdce7ea640757ba7ff13f1e45456898f970 /dirmngr/Makefile.am
parentdoc: Describe the relation between pubring.gpg and pubring.kbx (diff)
downloadgnupg-32aac55875f324f8c3d85dad8483604eae65e3e8.tar.gz
gnupg-32aac55875f324f8c3d85dad8483604eae65e3e8.zip
build: New configure option --disable-tests
* configure.ac: Add option --disable-tests. Print warnings in the summary. (DISABLE_TESTS): New am_conditional. -- GnuPG-bug-id: 4960
Diffstat (limited to 'dirmngr/Makefile.am')
-rw-r--r--dirmngr/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 506a3f65d..77ca3f571 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -33,7 +33,11 @@ libexec_PROGRAMS =
endif
noinst_PROGRAMS = $(module_tests) $(module_net_tests) $(module_maint_tests)
+if DISABLE_TESTS
+TESTS =
+else
TESTS = $(module_tests) $(module_net_tests)
+endif
AM_CPPFLAGS =