aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2020-08-26 13:15:34 +0000
committerWerner Koch <[email protected]>2020-08-26 13:15:34 +0000
commit90a87d96eaf5b97cd53cb0ee0495b646be7b84bb (patch)
tree0d1da74492369b02e2ad26ac4e0d5f52bf2b8ae7 /configure.ac
parentspeedo: Allow customizing the release process (diff)
downloadgnupg-90a87d96eaf5b97cd53cb0ee0495b646be7b84bb.tar.gz
gnupg-90a87d96eaf5b97cd53cb0ee0495b646be7b84bb.zip
build: Silence gcc warning -Wformat-zero-length
* configure.ac: Avoid useless gcc warning. We use an empty string quite often, for example in log_printhex.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47d52fbdc..b76f18264 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1620,6 +1620,7 @@ if test "$GCC" = yes; then
if test x"$_gcc_wopt" = xyes ; then
mycflags="$mycflags -W -Wno-sign-compare -Wno-format-zero-length"
mycflags="$mycflags -Wno-missing-field-initializers"
+ mycflags="$mycflags -Wno-format-zero-length"
fi
AC_MSG_CHECKING([if gcc supports -Wdeclaration-after-statement])