aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2021-12-22 01:36:26 +0000
committerNIIBE Yutaka <[email protected]>2021-12-22 01:36:26 +0000
commit6b4441a7de9d7090bb3b1570a12e1e8bce0554cb (patch)
treea0e1df1e93cea48e5c949d7a02799d639ce6600a /configure.ac
parentpo: Update Japanese Translation. (diff)
downloadgnupg-6b4441a7de9d7090bb3b1570a12e1e8bce0554cb.tar.gz
gnupg-6b4441a7de9d7090bb3b1570a12e1e8bce0554cb.zip
build: Update for newer autoconf.
* configure.ac (AC_PREREQ): Use >= 2.69. (AC_CONFIG_HEADERS): Use it, instead of AC_CONFIG_HEADER. (AC_HEADER_STDC, AC_HEADER_TIME): Remove obsolete macros. (sys/time.h): Add the check of the header. (time_t): Don't use TIME_WITH_SYS_TIME. * acinclude.m4 (AC_HEADER_TIME): Don't require. Don't use TIME_WITH_SYS_TIME. * dirmngr/dns.c: Don't use TIME_WITH_SYS_TIME. -- Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 5 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 69e9760b3..f61586712 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,7 @@
# along with this program; if not, see <https://www.gnu.org/licenses/>.
# Process this file with autoconf to produce a configure script.
-AC_PREREQ([2.61])
+AC_PREREQ([2.69])
min_automake_version="1.16.3"
# To build a release you need to create a tag with the version number
@@ -83,7 +83,7 @@ VERSION=$PACKAGE_VERSION
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_SRCDIR([sm/gpgsm.c])
-AC_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([serial-tests dist-bzip2 no-dist-gzip])
AC_CANONICAL_HOST
AB_INIT
@@ -1360,10 +1360,8 @@ fi
# Checks for header files.
#
AC_MSG_NOTICE([checking for header files])
-AC_HEADER_STDC
-AC_HEADER_TIME
AC_CHECK_HEADERS([unistd.h langinfo.h termio.h locale.h \
- pwd.h inttypes.h signal.h sys/select.h \
+ pwd.h inttypes.h signal.h sys/select.h sys/time.h \
stdint.h signal.h termios.h \
ucred.h sys/ucred.h sys/sysmacros.h sys/mkdev.h])
@@ -1408,15 +1406,10 @@ AC_CHECK_SIZEOF(unsigned long long)
AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(time_t,,[[
#include <stdio.h>
-#if TIME_WITH_SYS_TIME
+#ifdef HAVE_SYS_TIME_H
# include <sys/time.h>
-# include <time.h>
#else
-# if HAVE_SYS_TIME_H
-# include <sys/time.h>
-# else
-# include <time.h>
-# endif
+# include <time.h>
#endif
]])
GNUPG_TIME_T_UNSIGNED