aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2020-02-20 09:03:11 +0000
committerWerner Koch <[email protected]>2020-02-20 10:13:32 +0000
commit0e8f6e2aa98c212442001036fb5178cd6cd8af59 (patch)
treee5e6fa4b94889eff428598e64b0d093702bc02b4 /configure.ac
parentbuild: Require libgpg-error 1.38 (diff)
downloadgnupg-0e8f6e2aa98c212442001036fb5178cd6cd8af59.tar.gz
gnupg-0e8f6e2aa98c212442001036fb5178cd6cd8af59.zip
gpg: Use gpgrt's new option parser to provide a global conf file.
* common/util.h: Remove argparse.h. * common/argparse.c: Undef GPGRT_ENABLE_ARGPARSE_MACROS. * configure.ac (GPGRT_ENABLE_ARGPARSE_MACROS): Define. * agent/gpg-agent.c: Undef GPGRT_ENABLE_ARGPARSE_MACROS and include argparse.h. Do this also for all main modules which use our option parser except for gpg. Replace calls to strusage by calls to gpgrt_strusage everywhere. * g10/gpg.c (opts): Change type to gpgrt_opt_t. Flag oOptions and oNoOptions with ARGPARSE_conffile and ARGPARSE_no_conffile. (main): Change type of pargs to gpgrt_argparse_t. Rework the option parser to make use of the new gpgrt_argparser. -- This is not yet finished but a make check works. gpg has the most complex and oldest option handling and thus this is the first migration target. SE-Linux checks and version-ed config files are missing and will be added later. GnuPG-bug-id: 4788 Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5fcbcd7e4..0815927ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -522,7 +522,7 @@ AH_BOTTOM([
#define GNUPG_CACHE_DIR "cache.d"
#define GNUPG_DEF_COPYRIGHT_LINE \
- "Copyright (C) 2018 Free Software Foundation, Inc."
+ "Copyright (C) 2020 Free Software Foundation, Inc."
/* For some systems (DOS currently), we hardcode the path here. For
POSIX systems the values are constructed by the Makefiles, so that
@@ -580,6 +580,9 @@ AH_BOTTOM([
/* Enable the log_ macros from gpgrt. */
#define GPGRT_ENABLE_LOG_MACROS 1
+/* We want the argparse macros from gpgrt. */
+#define GPGRT_ENABLE_ARGPARSE_MACROS 1
+
/* Tell libgcrypt not to use its own libgpg-error implementation. */
#define USE_LIBGPG_ERROR 1