aboutsummaryrefslogtreecommitdiffstats
path: root/agent/Makefile.am
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2017-03-20 09:30:08 +0000
committerJustus Winter <[email protected]>2017-05-11 16:12:37 +0000
commitf4365790daa1d1400c7f0fe73ac9a6d25f0c6d0a (patch)
tree67fadb83cbe030e2a402cd7c356228f38bd19ae0 /agent/Makefile.am
parenttests: Move the makefile parser. (diff)
downloadgnupg-f4365790daa1d1400c7f0fe73ac9a6d25f0c6d0a.tar.gz
gnupg-f4365790daa1d1400c7f0fe73ac9a6d25f0c6d0a.zip
tests: Make it possible to run all tests using our infrastructure.
* Makefile.am (TESTS_ENVIRONMENT): New variable. (check-all): New phony target to run all tests. * tests/gpgme/gpgme-defs.scm (have-gpgme?): New function that tests whether the GPGME test suite is available instead of exiting the process. * tests/gpgscm/init.scm (export): New macro. * tests/gpgscm/tests.scm (run-tests): New function. (load-tests): Likewise. * tests/gpgme/run-tests.scm: Simplify and move the parsing of the list of tests to 'all-tests.scm'. * tests/gpgsm/run-tests.scm: Likewise. * tests/migrations/run-tests.scm: Likewise. * tests/openpgp/run-tests.scm: Likewise. * tests/gpgme/Makefile.am: To select the tests to run, use the variable 'TESTS'. This harmonizes the interface with the automake test suite. * tests/gpgsm/Makefile.am: Likewise. * tests/migrations/Makefile.am: Likewise. * tests/openpgp/Makefile.am: Likewise. * tests/openpgp/README: Likewise. * agent/all-tests.scm: New file. * common/all-tests.scm: Likewise. * g10/all-tests.scm: Likewise. * g13/all-tests.scm: Likewise. * tests/gpgme/all-tests.scm: Likewise. * tests/gpgsm/all-tests.scm: Likewise. * tests/migrations/all-tests.scm: Likewise. * tests/openpgp/all-tests.scm: Likewise. * tests/run-tests.scm: Likewise. -- This change allows us to run all tests in parallel and write one XML report capturing the results of every test. It also lays the foundation to parametrize test suites. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'agent/Makefile.am')
-rw-r--r--agent/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 668de2a29..ce29462b2 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -25,7 +25,7 @@ libexec_PROGRAMS += gpg-preset-passphrase
endif
noinst_PROGRAMS = $(TESTS)
-EXTRA_DIST = ChangeLog-2011 gpg-agent-w32info.rc
+EXTRA_DIST = ChangeLog-2011 gpg-agent-w32info.rc all-tests.scm
AM_CPPFLAGS =