aboutsummaryrefslogtreecommitdiffstats
path: root/agent/Makefile.am
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2006-09-06 20:57:57 +0000
committerMarcus Brinkmann <[email protected]>2006-09-06 20:57:57 +0000
commitbffa1dcf6e7cf96a831cd0dbecd554d57e207b00 (patch)
treedac7491d018b56f6800d107319e8c0cbb692f952 /agent/Makefile.am
parentThe big Assuan error code removal. (diff)
downloadgnupg-bffa1dcf6e7cf96a831cd0dbecd554d57e207b00.tar.gz
gnupg-bffa1dcf6e7cf96a831cd0dbecd554d57e207b00.zip
2006-09-06 Marcus Brinkmann <[email protected]>
* Makefile.am (AM_CFLAGS): Add $(GPG_ERR_CFLAGS). (gpg_agent_LDADD): Replace -lgpg-error with $(GPG_ERROR_LIBS).
Diffstat (limited to 'agent/Makefile.am')
-rw-r--r--agent/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 0bccefab2..36baa9504 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -27,7 +27,8 @@ AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/common -I$(top_srcdir)/intl
include $(top_srcdir)/am/cmacros.am
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(PTH_CFLAGS)
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(GPG_ERROR_CFLAGS) \
+ $(PTH_CFLAGS)
gpg_agent_SOURCES = \
gpg-agent.c agent.h \
@@ -48,7 +49,7 @@ gpg_agent_SOURCES = \
gpg_agent_LDADD = ../jnlib/libjnlib.a ../common/libcommon.a ../gl/libgnu.a \
$(LIBGCRYPT_LIBS) $(PTH_LIBS) $(LIBASSUAN_LIBS) \
- -lgpg-error @LIBINTL@ $(NETLIBS)
+ $(GPG_ERROR_LIBS) @LIBINTL@ $(NETLIBS)
gpg_protect_tool_SOURCES = \
protect-tool.c \