aboutsummaryrefslogtreecommitdiffstats
path: root/agent/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2006-10-17 14:34:42 +0000
committerWerner Koch <[email protected]>2006-10-17 14:34:42 +0000
commitbe410be660305328787559a18b8c9b69790dbfe8 (patch)
tree32a7dd94b21d1973c1ceedc3d71e13df34f0c83b /agent/Makefile.am
parentFixed aegypten bug 372 (diff)
downloadgnupg-be410be660305328787559a18b8c9b69790dbfe8.tar.gz
gnupg-be410be660305328787559a18b8c9b69790dbfe8.zip
Pth tweaks and improved estream.c
Diffstat (limited to 'agent/Makefile.am')
-rw-r--r--agent/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 27cde6524..b92543910 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -27,8 +27,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/common -I$(top_srcdir)/intl
include $(top_srcdir)/am/cmacros.am
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_PTH_CFLAGS) $(GPG_ERROR_CFLAGS) \
- $(PTH_CFLAGS)
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
gpg_agent_SOURCES = \
gpg-agent.c agent.h \
@@ -48,9 +47,11 @@ gpg_agent_SOURCES = \
common_libs = ../jnlib/libjnlib.a ../common/libcommon.a ../gl/libgnu.a
+commonpth_libs = ../jnlib/libjnlib.a ../common/libcommonpth.a ../gl/libgnu.a
pwquery_libs = ../common/libsimple-pwquery.a
-gpg_agent_LDADD = $(common_libs) \
+gpg_agent_CFLAGS = $(AM_CFLAGS) $(LIBASSUAN_PTH_CFLAGS) $(PTH_CFLAGS)
+gpg_agent_LDADD = $(commonpth_libs) \
$(LIBGCRYPT_LIBS) $(LIBASSUAN_PTH_LIBS) $(PTH_LIBS) \
$(GPG_ERROR_LIBS) $(LIBINTL) $(NETLIBS)
@@ -61,24 +62,19 @@ gpg_protect_tool_SOURCES = \
# Needs $(NETLIBS) for libsimple-pwquery.la.
gpg_protect_tool_LDADD = $(pwquery_libs) $(common_libs) \
- $(LIBGCRYPT_LIBS) -lgpg-error $(LIBINTL) $(NETLIBS)
-if HAVE_W32_SYSTEM
-gpg_protect_tool_LDADD += -lwsock32
-endif
+ $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(NETLIBS)
gpg_preset_passphrase_SOURCES = \
preset-passphrase.c
# Needs $(NETLIBS) for libsimple-pwquery.la.
gpg_preset_passphrase_LDADD = $(pwquery_libs) $(common_libs) \
- $(LIBGCRYPT_LIBS) -lgpg-error @LIBINTL@ $(NETLIBS)
-if HAVE_W32_SYSTEM
-gpg_preset_passphrase_LDADD += -lwsock32
-endif
+ $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(NETLIBS)
+
# Make sure that all libs are build before we use them. This is
# important for things like make -j2.
-$(PROGRAMS): $(common_libs) $(pwquery_libs)
+$(PROGRAMS): $(common_libs) $(commonpth_libs) $(pwquery_libs)
#