aboutsummaryrefslogtreecommitdiffstats
path: root/agent/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2022-04-26 02:13:54 +0000
committerNIIBE Yutaka <[email protected]>2022-04-26 02:13:54 +0000
commita9754879d127fd492606327b7397350f094f3ff4 (patch)
tree03fc5362e47b0338ebb914655ce8431132e2ad8d /agent/Makefile.am
parenttests: Skip testsing g13 when it's not enabled. (diff)
downloadgnupg-a9754879d127fd492606327b7397350f094f3ff4.tar.gz
gnupg-a9754879d127fd492606327b7397350f094f3ff4.zip
tests: Use module_tests for testing agent/.
* agent/Makefile.am (module_test): New. * agent/all-tests.scm: Use module_tests instead of TESTS. -- Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to 'agent/Makefile.am')
-rw-r--r--agent/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/agent/Makefile.am b/agent/Makefile.am
index d5998c71c..fe2d7d222 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -111,10 +111,12 @@ $(PROGRAMS): $(common_libs) $(commonpth_libs) $(pwquery_libs)
#
# Module tests
#
+module_tests = t-protect
+
if DISABLE_TESTS
TESTS =
else
-TESTS = t-protect
+TESTS = $(module_tests)
endif
t_common_ldadd = $(common_libs) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \