aboutsummaryrefslogtreecommitdiffstats
path: root/agent/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2023-05-24 10:06:37 +0000
committerWerner Koch <[email protected]>2023-05-24 10:14:06 +0000
commit3a438a1cc3505390e5e1a33ebbf1bd87d7a22840 (patch)
tree69fb1f9607721865c70f0442059c40427a78aa6a /agent/Makefile.am
parentcommon,w32: Set a proper error code when creating an output file. (diff)
downloadgnupg-3a438a1cc3505390e5e1a33ebbf1bd87d7a22840.tar.gz
gnupg-3a438a1cc3505390e5e1a33ebbf1bd87d7a22840.zip
w32: Add missing manifests and set a requestedExecutionLevel.
* agent/gpg-agent.w32-manifest.in: New. * dirmngr/dirmngr-client-w32info.rc: New. * dirmngr/dirmngr-client.w32-manifest.in: New. * dirmngr/dirmngr-w32info.rc: New. * dirmngr/dirmngr.w32-manifest.in: New. * dirmngr/dirmngr_ldap-w32info.rc: New. * dirmngr/dirmngr_ldap.w32-manifest.in: New. * g10/gpgv-w32info.rc: New. * g10/gpgv.w32-manifest.in: New. * kbx/keyboxd.w32-manifest.in: New. * scd/scdaemon.w32-manifest.in: New. * sm/gpgsm.w32-manifest.in: New. -- This avoids the use of the VirtualStore uner Windows. GnuPG-bug-id: 6503
Diffstat (limited to 'agent/Makefile.am')
-rw-r--r--agent/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 4da1ea9d8..b2a32b1fd 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -1,3 +1,4 @@
+# Makefile.am - agent
# Copyright (C) 2001, 2003, 2004, 2005 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
@@ -23,8 +24,8 @@ libexec_PROGRAMS = gpg-protect-tool
libexec_PROGRAMS += gpg-preset-passphrase
noinst_PROGRAMS = $(TESTS)
-EXTRA_DIST = ChangeLog-2011 gpg-agent-w32info.rc all-tests.scm
-
+EXTRA_DIST = ChangeLog-2011 all-tests.scm \
+ gpg-agent-w32info.rc gpg-agent.w32-manifest.in
AM_CPPFLAGS =
@@ -32,6 +33,8 @@ include $(top_srcdir)/am/cmacros.am
if HAVE_W32_SYSTEM
resource_objs += gpg-agent-w32info.o
+
+gpg-agent-w32info.o : gpg-agent.w32-manifest ../common/w32info-rc.h
endif
AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)