aboutsummaryrefslogtreecommitdiffstats
path: root/agent/Makefile.am
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-08-11 10:26:09 +0000
committerJustus Winter <[email protected]>2016-08-11 10:49:30 +0000
commit14479e2515439c73e385f37e8c2b3fc517b038b9 (patch)
tree179c37c1dd47b48e26447acb9a4955f4b6205ccd /agent/Makefile.am
parentcommon: Remove simple password query error codes. (diff)
downloadgnupg-14479e2515439c73e385f37e8c2b3fc517b038b9.tar.gz
gnupg-14479e2515439c73e385f37e8c2b3fc517b038b9.zip
common: Rework the simple password query module.
* common/simple-pwquery.c (writen, readline): Drop. (agent_send_option, agent_send_all_options, agent_open): Just use libassuan. (simple_pw_set_socket): Simplify. (default_inq_cb): New function. (simple_pwquery, simple_query): Just use libassuan. * agent/Makefile.am (gpg_preset_passphrase_LDADD): Add libassuan. * tools/Makefile.am (symcryptrun_LDADD): Likewise. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'agent/Makefile.am')
-rw-r--r--agent/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 4be9090af..19700888b 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -85,7 +85,7 @@ gpg_preset_passphrase_SOURCES = \
# Needs $(NETLIBS) for libsimple-pwquery.la.
gpg_preset_passphrase_LDADD = \
- $(pwquery_libs) $(common_libs) \
+ $(pwquery_libs) $(common_libs) $(LIBASSUAN_LIBS) \
$(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(NETLIBS) $(LIBICONV)