aboutsummaryrefslogtreecommitdiffstats
path: root/src/m_pinentry/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/m_pinentry/CMakeLists.txt')
-rw-r--r--src/m_pinentry/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/m_pinentry/CMakeLists.txt b/src/m_pinentry/CMakeLists.txt
index c8b8473..b1e19bc 100644
--- a/src/m_pinentry/CMakeLists.txt
+++ b/src/m_pinentry/CMakeLists.txt
@@ -27,7 +27,8 @@ aux_source_directory(. INTEGRATED_MODULE_SOURCE)
# capslock
list(APPEND INTEGRATED_MODULE_SOURCE "capslock/capslock.cpp")
-if (MINGW)
+
+if(MINGW)
list(APPEND INTEGRATED_MODULE_SOURCE "capslock/capslock_win.cpp")
else()
list(APPEND INTEGRATED_MODULE_SOURCE "capslock/capslock_unix.cpp")
@@ -39,10 +40,9 @@ list(APPEND INTEGRATED_MODULE_SOURCE "pinentry.qrc")
add_library(mod_pinentry SHARED ${INTEGRATED_MODULE_SOURCE})
# install dir
-install(TARGETS mod_pinentry
+install(TARGETS mod_pinentry
LIBRARY DESTINATION "${CMAKE_INSTALL_PREFIX}/modules")
-
# link options
# link sdk
@@ -57,7 +57,5 @@ else()
target_link_libraries(mod_pinentry PUBLIC Qt6::Widgets)
endif()
-
# using std c++ 17
target_compile_features(mod_pinentry PUBLIC cxx_std_17)
-