aboutsummaryrefslogtreecommitdiffstats
path: root/src/gpg_info/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gpg_info/CMakeLists.txt')
-rw-r--r--src/gpg_info/CMakeLists.txt65
1 files changed, 65 insertions, 0 deletions
diff --git a/src/gpg_info/CMakeLists.txt b/src/gpg_info/CMakeLists.txt
new file mode 100644
index 0000000..63127f5
--- /dev/null
+++ b/src/gpg_info/CMakeLists.txt
@@ -0,0 +1,65 @@
+# Copyright (C) 2021 Saturneric <[email protected]>
+#
+# This file is part of GpgFrontend.
+#
+# GpgFrontend is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# GpgFrontend is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GpgFrontend. If not, see <https://www.gnu.org/licenses/>.
+#
+# The initial version of the source code is inherited from
+# the gpg4usb project, which is under GPL-3.0-or-later.
+#
+# All the source code of GpgFrontend was modified and released by
+# Saturneric <[email protected]> starting on May 12, 2021.
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+# com.bktus.gpgfrontend.module.integrated.gnupg_info_gathering
+
+aux_source_directory(. INTEGRATED_MODULE_SOURCE)
+
+# define libgpgfrontend_module
+add_library(mod_gpg_info SHARED ${INTEGRATED_MODULE_SOURCE})
+set(_export_file "${CMAKE_CURRENT_SOURCE_DIR}/GFModuleExport.h")
+generate_export_header(mod_gpg_info
+ BASE_NAME "GF_MODULE"
+ EXPORT_FILE_NAME "${_export_file}")
+
+target_include_directories(mod_gpg_info PRIVATE
+ ${CMAKE_SOURCE_DIR}/third_party/spdlog/include)
+
+# set output directory
+set_target_properties(mod_gpg_info PROPERTIES
+ LIBRARY_OUTPUT_DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}
+ RUNTIME_OUTPUT_DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+
+# install dir
+install(TARGETS mod_gpg_info
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+
+# link sdk
+target_link_libraries(mod_gpg_info PRIVATE
+ gpgfrontend_module_sdk)
+
+if(GPGFRONTEND_QT5_BUILD)
+ # link Qt core
+ target_link_libraries(mod_gpg_info PRIVATE Qt5::Core)
+else()
+ # link Qt core
+ target_link_libraries(mod_gpg_info PRIVATE Qt6::Core)
+endif()
+
+# property
+set_property(TARGET mod_gpg_info PROPERTY AUTOMOC ON)
+
+# using std c++ 17
+target_compile_features(mod_gpg_info PRIVATE cxx_std_17) \ No newline at end of file