aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 839203fd..2fc4b511 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -340,6 +340,10 @@ if (LINUX)
exec_program(uname OUTPUT_VARIABLE SYSTEM_NAME)
set(SYSTEM_NAME "${SYSTEM_NAME}" CACHE INTERNAL "")
+ if(USING_COMPILER_CLANG)
+ add_compile_options(-stdlib=libstdc++)
+ endif()
+
if(SYSTEM_NAME STREQUAL "FreeBSD")
message(STATUS "FreeBSD BOX")
ADD_DEFINITIONS(-DFREEBSD)