aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2023-10-27 13:24:11 +0000
committersaturneric <[email protected]>2023-10-27 13:24:11 +0000
commitfcdcb6311c0af72f2177dc3a943a4b22ba393eda (patch)
tree5bf99cee8bb5cd1463d83e919fa5ff85530eb212 /CMakeLists.txt
parentfeat: improve thread system and gathering gnupg options info to rt (diff)
downloadGpgFrontend-fcdcb6311c0af72f2177dc3a943a4b22ba393eda.tar.gz
GpgFrontend-fcdcb6311c0af72f2177dc3a943a4b22ba393eda.zip
chore: use libstdc++ when using clang on linux platform
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 839203fd..2fc4b511 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -340,6 +340,10 @@ if (LINUX)
exec_program(uname OUTPUT_VARIABLE SYSTEM_NAME)
set(SYSTEM_NAME "${SYSTEM_NAME}" CACHE INTERNAL "")
+ if(USING_COMPILER_CLANG)
+ add_compile_options(-stdlib=libstdc++)
+ endif()
+
if(SYSTEM_NAME STREQUAL "FreeBSD")
message(STATUS "FreeBSD BOX")
ADD_DEFINITIONS(-DFREEBSD)