aboutsummaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-11-30 22:01:05 +0000
committersaturneric <[email protected]>2024-11-30 22:01:05 +0000
commit9d082b3c9d351160d8d9c992a58ce1c66094e17c (patch)
treee2bf9b62f051514509c85865ab82d12f946f243d /src/core/CMakeLists.txt
parentfeat: improve app structure on windows (diff)
downloadGpgFrontend-9d082b3c9d351160d8d9c992a58ce1c66094e17c.tar.gz
GpgFrontend-9d082b3c9d351160d8d9c992a58ce1c66094e17c.zip
fix: debug lib and runtime output dir should be same as release
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 90409e22..3ce199e5 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -92,13 +92,6 @@ target_precompile_headers(gpgfrontend_core
# using std c++ 17
target_compile_features(gpgfrontend_core PUBLIC cxx_std_17)
-if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
- # lib output path
- set_target_properties(gpgfrontend_core PROPERTIES
- LIBRARY_OUTPUT_DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/lib
- RUNTIME_OUTPUT_DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/lib)
-endif()
-
# link for different platforms
if(MINGW)
message(STATUS "Link GPG Static Library For MINGW")