aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-30 18:48:25 +0000
committersaturneric <[email protected]>2024-07-30 18:48:25 +0000
commit99c1b2c3ed902969d8940e384ff9fcd2805098b0 (patch)
treea86ab01bbe3f85318f869ffdebfcba623be6a857 /src/CMakeLists.txt
parentfeat: simplify logging (diff)
downloadGpgFrontend-99c1b2c3ed902969d8940e384ff9fcd2805098b0.tar.gz
GpgFrontend-99c1b2c3ed902969d8940e384ff9fcd2805098b0.zip
fix: do clean up
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt37
1 files changed, 32 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index eb7766a1..ddbc0fae 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -304,9 +304,34 @@ if(BUILD_APPLICATION AND MINGW)
set(ALL_RUNTIME_DLL_FILES "")
if(GPGFRONTEND_QT5_BUILD)
- list(APPEND ALL_RUNTIME_DLL_FILES "Qt5Core.dll;Qt5Gui.dll;Qt5Network.dll;Qt5PrintSupport.dll;Qt5Svg.dll;Qt5Widgets.dll;libbrotlicommon.dll;libbrotlidec.dll;libdouble-conversion.dll;libzstd.dll;libmd4c.dll;")
+ list(APPEND ALL_RUNTIME_DLL_FILES
+ "Qt5Core.dll"
+ "Qt5Gui.dll"
+ "Qt5Network.dll"
+ "Qt5PrintSupport.dll"
+ "Qt5Svg.dll"
+ "Qt5Widgets.dll"
+ "libbrotlicommon.dll"
+ "libbrotlidec.dll"
+ "libdouble-conversion.dll"
+ "libzstd.dll"
+ "libmd4c.dll"
+ )
else()
- list(APPEND ALL_RUNTIME_DLL_FILES "Qt6Core.dll;Qt6Core5Compat.dll;Qt6Gui.dll;Qt6Network.dll;Qt6PrintSupport.dll;Qt6Svg.dll;Qt6Widgets.dll;libbrotlicommon.dll;libbrotlidec.dll;libdouble-conversion.dll;libzstd.dll;libmd4c.dll;")
+ list(APPEND ALL_RUNTIME_DLL_FILES
+ "Qt6Core.dll"
+ "Qt6Core5Compat.dll"
+ "Qt6Gui.dll"
+ "Qt6Network.dll"
+ "Qt6PrintSupport.dll"
+ "Qt6Svg.dll"
+ "Qt6Widgets.dll"
+ "libbrotlicommon.dll"
+ "libbrotlidec.dll"
+ "libdouble-conversion.dll"
+ "libzstd.dll"
+ "libmd4c.dll"
+ )
endif()
# find the other dlls
@@ -320,7 +345,9 @@ if(BUILD_APPLICATION AND MINGW)
message(STATUS "DLL: ${_dllFileName} , ITS Full Path is ${_runtimeDllLocalPath}")
endforeach()
- message(STATUS "All the Application Runtime Dependencies Path: ${ALL_RUNTIME_DEP_PATH_LIST}")
+ foreach(_dllDepPath ${ALL_RUNTIME_DEP_PATH_LIST})
+ message(STATUS "Runtime DLL Dependency Path: ${_dllDepPath}")
+ endforeach()
# copy dependencies to release path
foreach(_dllRuntimeFilePath ${ALL_RUNTIME_DEP_PATH_LIST})
@@ -439,7 +466,8 @@ endif()
# add i18n support
if(BUILD_APPLICATION)
set(LOCALE_TS_PATH ${CMAKE_SOURCE_DIR}/resource/lfs/locale/ts)
- set(TS_FILES "${LOCALE_TS_PATH}/GpgFrontend.en_US.ts"
+ set(TS_FILES
+ "${LOCALE_TS_PATH}/GpgFrontend.en_US.ts"
"${LOCALE_TS_PATH}/GpgFrontend.de_DE.ts"
"${LOCALE_TS_PATH}/GpgFrontend.fr_FR.ts"
"${LOCALE_TS_PATH}/GpgFrontend.zh_CN.ts"
@@ -479,7 +507,6 @@ if(BUILD_APPLICATION)
qt5_add_resources(GF_I18N_RESOURCES ${QT_QM_TRANSLATIONS_RESOURCE_FILE})
message(STATUS "GF_I18N_RESOURCES ${GF_I18N_RESOURCES}")
-
target_sources(${AppName} PRIVATE ${GF_I18N_RESOURCES})
else()
add_custom_target(gftranslations ALL)