aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-25 17:15:21 +0000
committersaturneric <[email protected]>2024-07-25 17:15:21 +0000
commit85eff35d7bf01ede96629a32358c467041c9b0a3 (patch)
tree337db8c08e84fb69333336ed6459892d32b00cd8 /src/CMakeLists.txt
parentfix: update GeneralSettings ui file (diff)
downloadGpgFrontend-85eff35d7bf01ede96629a32358c467041c9b0a3.tar.gz
GpgFrontend-85eff35d7bf01ede96629a32358c467041c9b0a3.zip
fix: Qt6CoreConfigureFileTemplate.in does not exist
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt21
1 files changed, 1 insertions, 20 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 684a9e4a..ab6d0dbb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -51,27 +51,8 @@ if (APPLE)
message(FATAL_ERROR "OpenSSL not found in the standard directories. Please install it or set OPENSSL_ROOT_DIR manually.")
endif()
endif()
-find_package(OpenSSL REQUIRED)
-
-
-if(GPGFRONTEND_QT5_BUILD)
- # Introduce Qt
- # Support Qt version: 5.15.x
- find_package(Qt5 5.15 COMPONENTS Core Widgets PrintSupport Network LinguistTools REQUIRED)
-else()
- # Introduce Qt
- # Support Qt version: 6.x
- find_package(Qt6 6 COMPONENTS Core Widgets PrintSupport Network LinguistTools REQUIRED)
-endif()
-
-# Qt configuration
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(CMAKE_AUTORCC_OPTIONS "--compress;9")
-set(CMAKE_AUTOUIC_SEARCH_PATHS ${CMAKE_AUTOUIC_SEARCH_PATHS} ${CMAKE_SOURCE_DIR}/ui)
+find_package(OpenSSL REQUIRED)
# Set Build Information
configure_file(${CMAKE_SOURCE_DIR}/src/GpgFrontend.h.in ${CMAKE_SOURCE_DIR}/src/GpgFrontend.h @ONLY)