aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-28 20:44:37 +0000
committersaturneric <[email protected]>2024-07-28 20:44:37 +0000
commit28b2798015633e0186fa2084f9e9803f0fea5ba0 (patch)
treea81710d36407cddee03bbc5e9f48351d8399739e /src/CMakeLists.txt
parentfix: some build issues of github actions (diff)
downloadGpgFrontend-28b2798015633e0186fa2084f9e9803f0fea5ba0.tar.gz
GpgFrontend-28b2798015633e0186fa2084f9e9803f0fea5ba0.zip
fix: do not use mimalloc on macos and solve windows build issues on github actions
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b6702191..5496572c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -311,14 +311,6 @@ if (BUILD_APPLICATION)
if (${CMAKE_BUILD_TYPE} STREQUAL "Release")
if (MINGW)
add_executable(${AppName} WIN32 ${BASE_SOURCE} ${RESOURCE_FILES})
- # include qt dependencies
- if(NOT Qt6_DIR)
- add_custom_command(TARGET ${AppName} POST_BUILD
- COMMAND windeployqt --force --libdir ${CMAKE_RUNTIME_OUTPUT_DIRECTORY} --release ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${AppName}.exe)
- else()
- add_custom_command(TARGET ${AppName} POST_BUILD
- COMMAND windeployqt-qt6.exe --force --libdir ${CMAKE_RUNTIME_OUTPUT_DIRECTORY} --release ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${AppName}.exe)
- endif()
elseif (LINUX AND NOT LINUX_INSTALL_SOFTWARE)
add_executable(${AppName} ${BASE_SOURCE} ${RESOURCE_FILES})