aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaturneric <[email protected]>2021-12-14 03:56:12 +0000
committerSaturneric <[email protected]>2021-12-14 04:55:56 +0000
commitc77a3c560ebcb06a5ca4214cbfdd688e5f9e32cb (patch)
treefc0ddd6f2f50bd87a00919de30584925d5be0417 /CMakeLists.txt
parentUpdate Translations & README. (diff)
downloadGpgFrontend-c77a3c560ebcb06a5ca4214cbfdd688e5f9e32cb.tar.gz
GpgFrontend-c77a3c560ebcb06a5ca4214cbfdd688e5f9e32cb.zip
Add Deb Build Support & Install Support For Linux.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 377f627c..d5c6a8d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -222,6 +222,18 @@ set(BASIC_ENV_CONFIG 1)
set(QT_MOC_CONFIG 1)
set(ESAY_LOGGING_PP 1)
+if (LINUX_INSTALL_SOFTWARE)
+ include(GNUInstallDirs)
+ set(INSTALL_GPGFRONTEND_APP 1)
+ set(APP_INSTALL_FLAG LINUX_INSTALL)
+ add_compile_definitions(LINUX_INSTALL_BUILD)
+ set(Boost_USE_STATIC_LIBS ON)
+else ()
+ set(APP_INSTALL_FLAG BUNDLE)
+ add_compile_definitions(BUNDLE_BUILD)
+endif ()
+
+
if (FULL_APPLICATION_BUILD)
message(STATUS "Build Full Application")
set(QT5_ENV_SUPPORT 1)